Error running rails server after installing gem using bundle install


#1

Hi I am getting the following error below after installing the gem by adding

gem ‘rack-mini-profiler’ to Gemfile and executing bundle install and then calling rails s

Below is the call stack. What is the issue? I have ruby version 1.8.7 and rails 3.2

[email protected] ~/D/c/b/openslot> rails s
/Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/activesupport-3.2.0/lib/active_support/dependencies.rb:251:in require': /Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/rack-mini-profiler-0.1.18/lib/mini_profiler/profiler.rb:375: syntax error, unexpected ')', expecting '=' (SyntaxError) /Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/rack-mini-profiler-0.1.18/lib/mini_profiler/profiler.rb:474: syntax error, unexpected kEND, expecting $end from /Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/activesupport-3.2.0/lib/active_support/dependencies.rb:251:inrequire’
from /Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/activesupport-3.2.0/lib/active_support/dependencies.rb:236:in load_dependency' from /Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/activesupport-3.2.0/lib/active_support/dependencies.rb:251:inrequire’
from /Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/rack-mini-profiler-0.1.18/lib/rack-mini-profiler.rb:1
from /Users/ankur/.rvm/gems/[email protected]/gems/bundler-1.2.0/lib/bundler/runtime.rb:68:in require' from /Users/ankur/.rvm/gems/[email protected]/gems/bundler-1.2.0/lib/bundler/runtime.rb:68:inrequire’
from /Users/ankur/.rvm/gems/[email protected]/gems/bundler-1.2.0/lib/bundler/runtime.rb:66:in each' from /Users/ankur/.rvm/gems/[email protected]/gems/bundler-1.2.0/lib/bundler/runtime.rb:66:inrequire’
from /Users/ankur/.rvm/gems/[email protected]/gems/bundler-1.2.0/lib/bundler/runtime.rb:55:in each' from /Users/ankur/.rvm/gems/[email protected]/gems/bundler-1.2.0/lib/bundler/runtime.rb:55:inrequire’
from /Users/ankur/.rvm/gems/[email protected]/gems/bundler-1.2.0/lib/bundler.rb:128:in require' from /Users/ankur/Desktop/code/bugfixes/openslot/config/application.rb:7 from /Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/railties-3.2.0/lib/rails/commands.rb:53:inrequire’
from /Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/railties-3.2.0/lib/rails/commands.rb:53
from /Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/railties-3.2.0/lib/rails/commands.rb:50:in tap' from /Users/ankur/.rvm/gems/ruby-1.8.7-p370/gems/railties-3.2.0/lib/rails/commands.rb:50 from script/rails:6:inrequire’
from script/rails:6


#2

just pushed 0.1.19 to fix this issue. was a 1.8.7 compat issue