Doesn't show in Dev environment after adding gem


#1

Hi.

I’m having problems with getting MiniProfiler to show me the reports. I’m just in the Dev environment, which should show it all the time. Adding ?pp=help does bring up the help page. In tmp/miniprofile, there are a ton of mp_timers_ files. Apparently something is happening back there.

At first I thought it was a weird CSS issue, like my navigation bar is covering it. I tried loading the page without CSS and the MiniProfile box still doesn’t show up.

In case it matters, I do have this before_filter set up:

def authorize_miniprofiler
  Rack::MiniProfiler.authorize_request if current_user.try(:admin?)
end

Any help would be great. This gem looks incredibly helpful.


#2

Have you looked at the html for the page generated? Is the profiler script included in the bottom of the file just before the end body tag?

Have you noticed any errors in chrome dev tools, is it getting 500s trying to request resources it needs?

What version of rails are you running?


#3

Hmm, I don’t see any profiler script before the body tag. Or anywhere. That’s probably it. Do I have to do anything manually?

In the Network tab, everything is either 200 or 304.

I’m on Rails 3.2.8, but it didn’t work with 3.2.5, either.


#4

Looking into it more, it looks like Miniprofiler is conflicting with the Mixpanel gem. It tries to inject a script, too. I’m guessing that’s the problem. So I’ll just be disabling it for now.


#5

awesome, thanks for letting me know that seems to be a real possibility, you can always manually insert the script for the time being