Deploying to Heroku?


#1

I’m not very experienced with RACK, or much more than writing my rails app and making it go. I put in miniprofiler today in our rails project that I need to do some performance fixes on and then put it up into production. I also followed the instructions here http://samsaffron.com/archive/2012/07/12/miniprofiler-ruby-edition about putting in a before filter, and only turn on profiling if the user is in the appropriate admin groups. Traced thru the code and it works fine in dev.

In production however, its not turning on. I don’t know if thats because:

  1. I need to flip a magic bit somewhere else to tell it to turn on in production
  2. I need to do something weird in Heroku to get it to play nice, or
  3. There’s no hope.

Anyone use this gem in heroku yet and have any feedback?

Cross posting this to StackOverflow too.


#2

My guess is that this could be a storage issue, if for any reason haroku is load balancing across multiple vms stuff can get weird.

To diagnose:

try:

If that is the case you should try the RedisStore


#3

Ok, that sort of worked (using Redis) but its pretty chaotic, probably due to Heroku’s environment. For example, I’ll hit the main page and not see anything, then go into a sub page and it will work. Then later, the main page starts working, or sometimes, it never does. Very strange, but totally understandable.

So let me ask a followup question: I have another environment I created called “devprod” which uses local dev server, but connects to production database. Since the main issues I’m having are long running queries in the production database (due to a lot of data) I’m thinking I’ll just do these performance investigations in devprod.

However, I can’t see pp=help when I run under that environment. Is there something different I need to do to make it work there?


#4

I think I am going to change the railtie, this keeps on tripping people https://github.com/SamSaffron/MiniProfiler/blob/master/Ruby/lib/mini_profiler_rails/railtie.rb (a more sane pull request - perhaps only disable in test)


#5

@Dave regarding hitting pages and seeing nothing, can you have a look at the google chrome network tab to see what is happening, are any requests failing?